Postman test request failing for REST API

Hi,

I’m brand new to working with NetSuite and am trying to call the Test Request method in the Postman collection, but it keeps failing with error code INVALID_LOGIN.  I’ve followed the setup steps outlined at https://5742286-sb1.app.netsuite.com/app/help/helpcenter.nl?fid=section_1545058149.html .  When I check the audit log, the details just say InvalidSignature.

I’m testing against our NetSuite sandbox, and per other posts I’ve read, I’ve confirmed that the account ID in my Postman environment uses an underscore (not a hyphen) and all caps (e.g. xxxx_SB1).

Just for testing purposes, the access token was created under my account, which is in the Administrator role – not sure if that causes any problems.  It’s assigned to the correct integration application.

Thank you for any assistance!

Rookie Asked on June 6, 2022 in SuiteTalk.
Add Comment
1 Answer(s)

Oh man, not sure how to delete this question, but chalk this up to user error – turns out when I copied the token ID, it included some sort of special character at the end.  I realized there was a very faint symbol in Postman that looked like a carriage return, and when I removed that the call worked.

The previous change I mentioned of changing the hyphen in the account ID to an underscore was still key though, since that was the other half of my original issue.

Rookie Answered on June 6, 2022.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.
  • This site made possible by our sponsors:   Tipalti   Celigo   Limebox   Become a Sponsor   Become a Sponsor