DeletedRecord not found and SystemNote empty

Hi

I’m having an issue trying to query this two tables using NetSuite2.com data source. For table DeletedRecord, it says it doesn’t exists but I can see it in the Records Catalog. For table SystemNote it says its empty but in NetSuite.com data source it has over 700 million records.

What am i missing? What am i doing wrong?

Please help!!

Add Comment
3 Answer(s)

Hi,

What role are you using with NetSuite2.com?

Thanks,

Chris

Intermediate Answered on January 21, 2022.
Add Comment

Hi, thanks for your reply.

We have two roles. The DWI role and a second role, which is a general role but has all the right permissions (at least we think so).

This second role was necessary to connect to NetSuite2.com data source using DBeaver. With the DWI role only (that uses TBA access) we can’t connect to it using DBeaver.

Thanks for any thoughts you may have on this.

Alois

Rookie Answered on January 21, 2022.
Add Comment

Thanks. Yeah – the token thing is going to be interesting for a lot of systems that are connecting!

On the deleted records side, has your general purpose role got Setup > Deleted Records permission?

Not sure what might be causing issues on the System Notes side though???

Intermediate Answered on January 24, 2022.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.
  • This site made possible by our sponsors:   Tipalti   Celigo   Limebox   Become a Sponsor   Become a Sponsor