Trouble when I save a transaction, after change the id of a custom field.

Hi guys. Hope you are well.

I changed the ID of some custom fields applied to the sales transactions and when I create a new Sales transaction (Sales Order/ Invoice). I get the following error:

You entered “ERROR: Field ‘custbody_taxable_total_sales_sv’ Not Found” into a field where a numeric value was expected. Please go back and change this value to a number.

“custbody_taxable_total_sales_sv” is one of the old IDs that I changed.

I ony get this error when I create a new transaction. I don’t get this error when I edit or copy a sale transaction.

What am I doing wrong? How can I fix this?

Thanks !!

Rookie Asked on April 11, 2021 in SuiteBuilder.
Add Comment
1 Answer(s)

One of the scripts in your account has not been changed to use the new field id. It also looks like its trying to catch the error and set the error message in the wrong field.

You need to find the script causing the problem and fix it. First place to start looking is Scripted Records 

Intermediate Answered on April 11, 2021.

Thanks for your answer.

I disabled the user event and client scripts for that transaction and got the same error.

But I found the error. There is a custom field that has a formula in its config, which uses the old ID and it was not updated. That formula throws the error and sets the custom field with that error.

Thanks for your help 🙂

on April 12, 2021.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.
  • This site made possible by our sponsors:   Tipalti   Celigo   Limebox   Become a Sponsor