How to show 4 Decimal Places in Report Builder Reports

How can I show up 4 decimal places on a report builder report? I am trying to have a report show Exchange Rate and on the Transaction record, it is showing 4 decimal places.

Ex. “0.7558”

But when I place that field on a report (not saved search), it seems to be showing only 2 decimal places and rounding up.

Is there a way to override this? This is necessary for data accuracy.

Thanks

Rookie Asked on December 29, 2020 in Reports.
Add Comment
1 Answer(s)

This is a limitation on NetSuite Reports. There is currently no way to override this. You can see they make a brief note regarding this limitation on Suite Answer 14969.

You can consider trying to create your report using a Suite Analytics Dataset + Workbook. The dataset pulls the data together, and the workbook gives some limited presentation options (e.g., Pivot Table) that may help you achieve your goals.

If that will not work, technically you could always customize your transaction records to add a field (probably line level) that copies the exchange rate and stores it as text. Then you could present the text field on reports. However, I usually advise against such work-arounds unless they are truly necessary. A couple solutions like this are fine, but it’s a slippery slope to a maintenance nightmare. Managing the data in a different field could lead to reporting mismatches if the field doesn’t update when expected (or is updated when not expected).

 

Rookie Answered on December 30, 2020.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.
  • This site made possible by our sponsors:   Tipalti   Celigo   Limebox   Become a Sponsor