Disable Inline Inactivate Checkbox on Vendor List

Hi all,

I’ve created a WF that inactivates Vendor records until they are approved by the designated User Role. The record has to remain inactive in order to prevent users from using unapproved Vendor records in transactions. However, one can still activate a record by using the “Show Inactives” checkbox on the list of Vendors, and ticking the checkbox next to an unaproved record.

Do you know if there’s a way to prevent a user from activating records in this fashion?

Thank you,

-K

Rookie Asked on February 27, 2020 in Vendors.

Hey Krishaj – Did you find a workaround to your problem?

on February 16, 2021.
Add Comment
2 Answer(s)

This is a good workaround:

“Workflow > User can edit locked record via Inline Editing” SuiteAnswers Id: 66747

or this (although, I prefer to script only in an emergency):

“Preventing Locked Records to be edited via Inline Editing using User Event Script” SuiteAnswers Id: 32739

Beginner Answered on March 2, 2020.
Add Comment

EDIT: Never mind,  spoke too soon. 66747 only works if the “Edit” slider is turned on on list view, otherwise the “Show Inactives” checkbox still populates and lets you activate the record. Will try the script next.

 

Hi James,

66747 works like a charm, thanks for your help!

Kind regards,

Kris

Rookie Answered on March 3, 2020.

Glad it worked out. This was a good question to post, as it’s a funky limitation that a lot of people aren’t aware of when designing workflows. You should mark my answer the best for those sweet sweet internet points 😉

on March 3, 2020.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.
  • This site made possible by our sponsors:   Tipalti   Celigo   Limebox   Become a Sponsor