Desperate for Bundle Help

So desperate for help here.

We had the Navigation Portlet installed in our sandbox, and dashboards set up to use the portlet. We created a bundle to deploy all our customizations to production — where the Navigation Portlet was already installed — it moved two of the portlet bundle’s files to our bundle’s directory. This obviously broke the portlet as it’s trying to require other files it expects to be in that directory but are not.

So I set off to try to fix it. I uninstalled the bundle from production, but the moved files were left behind in the bundle’s former directory. The files are locked and I can’t move them back from whence they came.

Anyone have any idea how I can extricate us from this problem?

 

Thanks!

Chris

Rookie Asked on October 21, 2019 in SuiteBundler.
Add Comment
1 Answer(s)

This sounds like you need to go to NetSuite support or the bundle provider (which is again Netsuite, in this case).  They should have some administrative tools to unlock the locked portions of the bundle, if that’s what’s needed.  This is also a cautionary tale in general about Bundling, that it (fairly frequently) picks up records that are linked in some way to the records you do want move.  It’s really important to review in detail what gets picked up in your bundle before you install it anywhere that’s not a sandbox account.  I’ve gotten burned by this a number of times myself, especially with saved searches, but I guess touching the hot stove makes sure you don’t forget next time.

Sorry I can’t provide more guidance, but it sounds like you’ve exhausted the basic troubleshooting steps of uninstall/reinstall all the bundles at issue.

Beginner Answered on October 23, 2019.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.
  • This site made possible by our sponsors:   Tipalti   Celigo   Limebox   Become a Sponsor