Fixed Assets won’t depreciate or show on Asset Report

I have imported mid life assets as instructed on SA with the relevant fields. Following on from that, I have also imported a historical depreciation record for each asset previously imported. However, when I then continue to run either the Depreciate assets transaction or Asset report, I get no results . Any pointers?

NO_DATA_FOR_REPORT: Report data is not available for the combination of filters you selected.

Should be 100 odd records!

 

Rookie Asked on September 13, 2019 in Fixed Asset Management.

can you add the screenshot?

on September 13, 2019.
Add Comment
2 Answer(s)

Look up SuiteAnswers 82184
https://netsuite.custhelp.com/app/answers/detail/a_id/82184

Scenario

Customer has encountered an error “NO_DATA_FOR_REPORT: Report data is not available for the combination of filters you selected” when trying to generate report. 

Solution

Possible sources of this error is that no depreciation histories (DHRs) have been generated for the asset. If there are DHRs associated, please double check whether depreciation expense has already been recorded for the asset such that there is journal entry associated with depreciation history covered by the parameters. You will know this by checking the posting reference column of the Depreciation History of the asset.

To illustrate, assuming that you generated Depreciation Monthly Report with the following parameters:

* Asset Type = AAA Type; Start Date = 1/1/2019 to End Date = 3/31/2019; Subsidiary = Subsidiary A

* If the depreciation histories covered by period 1/1/2019 to 3/31/2019 do not have any journal entries associated with them as indicated by posting reference, the error “NO_DATA_FOR_REPORT: Report data is not available for the combination of filters you selected” will be encountered

* The solution for this would be to perform Asset Depreciation involving the period 1/1/2019 to 3/31/2019 so that journal entry would be generated and this will be captured on the posting reference column of Depreciation History.

* After successful depreciation, users might try to generate the report again. Please ensure correct parameters, especially the dates, are used.

Advanced Answered on September 13, 2019.
Add Comment

Import Asset > No Asset Value generated

Published 05/30/2019 06:31 PM   |    Updated 08/06/2019 12:50 AM   |    Answer Id: 85337

Applies To

Product:  NetSuite 2019.1

Scenario

Customer imported Asset Records > Was not able to check on Run Server SuiteScript and trigger WorkFlows under Advanced Options during the importation process > Result: No Asset Value record generated by the system. 

Solution

To generate the corresponding Asset Value record of the imported Assets, the guidelines below should be followed:

1. Create a CSV template file with “Internal ID” alone as column header with the corresponding internal ID of the assets imported without asset value record generated by the system. 

2. Go to Setup > Import/Export > Import CSV Records.

3. Under Scan & Upload CSV File step, select the following parameters:

>Import Type=Custom Record

>Record Type= FAM Asset 

>Select the file

4. Under Import Options step:

>Data Handling=Update

>Advanced Options-check Run Server SuiteScript and trigger WorkFlows 

5. Under Field Mapping, map Internal ID to FAM Asset : Internal ID.

6. Save and Run

Once this is done, FAM Retrieve Asset Values MR should be ran. To do that, follow the guidelines below:

1. Go to Customization > Scripting > Script Deployment.

2. Look for the FAM Retrieve Asset Values MR deployment and click Edit.

3. In the Parameters tab > Asset ID field > enter the Internal ID of the assets separated by a comma.

4. Save and Execute.

Rookie Answered on November 19, 2019.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.
  • This site made possible by our sponsors:   Tipalti   Celigo   Limebox   Become a Sponsor   Become a Sponsor