RE: Why is this Workflow getting stuck?

Hey, I’m a relatively new NetSuite Administrator and have been more or less learning as I go. I’ve been trying to build a fairly basic email campaign workflow (New record -> send email -> wait a few days -> send another email -> wait a few days -> send another email etc) and am getting hung up. I’ve been banging my head against the wall for too long on this so I figured I would reach out for some help. Included below is a picture of the start of my workflow that I basically want to repeat.

 

Why is this Workflow getting stuck?

 

Note that right now I’m focused on making the first few states work. This is an entry based WF, it triggers when someone fills out a landing page on our website. This creates a record in NetSuite for them, and triggers this workflow. The trigger is working properly (I have the first state send me an email when a record enters). Where I’m running into an issue is with the delay. If I take the delay out completely on the transitions, the record moves straight through the workflow as intended. However, if I put a delay on the transition from the “Delay: 3 Days” state to the “Lead Nurturing Email #2” state, the record gets stuck in the “Delay: 3 Days” state even after the delay has passed. I’m not sure why.

 

It’s worth noting that all the transitions are on entry as well, as when I was doing scheduled it wouldn’t work even without a delay. If there’s any info I haven’t provided that would be useful, please let me know. If anyone could help point me in the right direction here that would be greatly appreciated.

For anyone still reading this, changing it to “Transition On” scheduled didn’t solve the problem. For reference, the transition that is giving me a hard time is below:

 

Why is this Workflow getting stuck?

STC Rookie Asked on September 27, 2019 in Administration.
Add Comment
3 Answers

One thing to look at is the workflow history on the record itself (I believe under system information). You will also see active workflows, which is where I believe you will find this workflow and the state that it is stuck in. Once you see that, you may have more clarity on where your logic isn’t passing from state to state to get to an end state.

Rookie Answered on September 27, 2019.

Yeah, so I’ve been checking that and it always gets stuck on the last state it was in before the delay transition. That’s why I’m pretty much convinced it’s an issue with the transition, or even somehow the delay itself.

on September 27, 2019.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.