RE: TBA Authorization Flow ERROR on step 1

Hi,

I’m facing an error on step 1 of “TBA Authorization Flow”. In the login audit trail the error is “MissingRequiredParameter” but already checked that all parameters are ok. I mean, actually it is only a POST request with one header parameter for authorization, here is the header log from axios:

 

_header: ‘POST /rest/requesttoken HTTP/1.1\r\n’ +
‘Accept: application/json, text/plain, */*\r\n’ +
‘Content-Type: application/json;charset=utf-8\r\n’ +
‘Authorization: OAuth realm=”TSTDRV2222222″, oauth_callback=”http%3A%2F%2Flocalhost%3A%2A”, oauth_consumer_key=”c22222222222222222222222222222222222222222222222222222226″, oauth_nonce=”fSB52CCYbuVWtoUBk6ci3rvZXTBv7Upb”, oauth_signature=”%2FxaMWVqkDHo2Y%2BGY98QIpLXG2SjeJQ0%2FUheu0RIx8tw%3D”, oauth_signature_method=”HMAC-SHA256″, oauth_timestamp=”1599683411″, oauth_version=”1.0″\r\n’ +
‘User-Agent: axios/0.20.0\r\n’ +
‘Content-Length: 2\r\n’ +
‘Host: tstdrv2222222.restlets.api.netsuite.com\r\n’ +
‘Connection: close\r\n’ +
‘\r\n’,

 

 

Do you know what may be wrong?

 

Thanks!

leonardosalatino Rookie Asked on September 9, 2020 in SuiteTalk.
Add Comment
6 Answers

How about consider including ‘role’ to your parameter?

Authorization: OAuth realm=”1234567″, role=”45678″, oauth_consumer_key=”60712990bc09623786e7047c226bcb3f86d49dca0b04efc21001dc76d97a81f5″, oauth_nonce=”bUvpxBX93OWo0FLswq5M”, oauth_timestamp=”1575998103″, oauth_signature_method=”HMAC-SHA256″, oauth_version=”1.0″, oauth_callback=”https%3A%2F%2Fmy.example.com%2FTBA%2F%3FcallbackRequest”, oauth_signature=”7kgwwmiAylqeMdHjCBnIUUW%2BdrDrGCbZGBkuCt39J90%3D”

Rookie Answered on September 10, 2020.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.