RE: Soap UI with Netsuite SOAP Webservice

Hi all,

I have a problem i always get the following error when i issue any soap request knowing that i have successfully made a connection and issued the getDataCenterUrls

You must use account-specific domains with the 2019.1

 

below is a sample of my request

 

<soapenv:Envelope xmlns:soapenv=”http://schemas.xmlsoap.org/soap/envelope/” xmlns:urn=”urn:messages_2019_2.platform.webservices.netsuite.com” xmlns:urn1=”urn:core_2019_2.platform.webservices.netsuite.com”>
<soapenv:Header>
<urn:tokenPassport>
<urn1:account>{{account}}</urn1:account>
<urn1:consumerKey>{{key}}</urn1:consumerKey>
<urn1:token>{{token}}</urn1:token>

</urn:tokenPassport>
</soapenv:Header>
<soapenv:Body>
<urn:getAll >
<urn:record recordType=”Vendor”/>
</urn:getAll>
</soapenv:Body>
</soapenv:Envelope>

abdo1200 Rookie Asked on February 19, 2020 in SuiteTalk.
Add Comment
1 Answers

The url that you are using for your request should use the domain found in https://system.na0.netsuite.com/app/common/otherlists/company.nl

You should also be able to find the urls in the response for getDataCenterUrls

Intermediate Answered on February 19, 2020.

thanks alot for the replay, but my problem is where i should use it in the request whether in the header of the request or the xmlns and how can i set an end point for the request. when i use https://{{my account}}.suitetalk.api.netsuite.com in the request  url it gets another error <title>Page Not Found</title>

on February 19, 2020.

The domain is only part of the url. You still need to use the correct path too.

For 2019.1, the path of the url should be /services/NetSuitePort_2019_1

on February 19, 2020.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.