RE: Item fulfillment request not created properly at netsuite using phptoolkit library

I have been working with netsuite phptoolkit sdk api library  to create Item fulfillment of sales order. But i am getting below error like ,
code => VALID_LINE_ITEM_REQD
[message] => You must have at least one valid line item for this transaction.
[type] => ERROR
Can anyone guide/help me to resolve this issue?
gmmankar Rookie Asked on April 22, 2020 in SuiteTalk.
Add Comment
1 Answers
Hi,
Based on my research  there are many factors on why this error occurs:
  • That line (item) doesn´t exists in the SO
  • That item doesn´t have available quantity (all backordered)
  • That line is closed
  • Wrong internalid for the item
  • Wrong location for the item
  • Item belongs to a different subsidiary
  • The Order is already having a conflicting ItemFulfillment record of it in NetSuite

Most common is that there is no quantity on hand/available for that particular item which you are trying to fulfill. You may need to check the list above to narrow down the specific cause.

Hope this helps.

Rookie Answered on October 19, 2021.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.